SI, ET, OU, fonctions logiques SI et NON imbriquées dans Excel

Les choses ne seront pas toujours comme nous le souhaitons. L'inattendu peut arriver. Par exemple, disons que vous devez diviser des nombres. Essayer de diviser n'importe quel nombre par zéro (0) donne une erreur. Les fonctions logiques sont utiles dans de tels cas. Dans ce tutoriel, nous allons aborder les éléments suivantswing sujets.

Qu'est-ce qu'une fonction logique ?

C'est une fonctionnalité qui nous permet d'introduire la prise de décision lors de l'exécution de formules et de fonctions. Les fonctions sont utilisées pour :

  • Vérifier si une condition est vraie ou fausse
  • Combiner plusieurs conditions ensemble

Qu’est-ce qu’une condition et pourquoi est-elle importante ?

Une condition est une expression qui est évaluée comme vraie ou fausse. L'expression peut être une fonction qui détermine si la valeur saisie dans une cellule est de type numérique ou texte, si une valeur est supérieure, égale ou inférieure à une valeur spécifiée, etc.

Exemple de fonction SI

Nous travaillerons avec le budget des fournitures pour la maison de ce tutoriel. Nous utiliserons la fonction IF pour déterminer si un article est cher ou non. Nous supposerons que les objets d’une valeur supérieure à 6,000 6,000 sont chers. Ceux qui coûtent moins de sont moins chers. Le suiviwing L'image nous montre l'ensemble de données avec lequel nous allons travailler.

Exemple de fonction SI dans Excel

  • Placez le focus du curseur dans la cellule F4
  • Entrez le suiviwing formule qui utilise la fonction SI

=SI(E4<6000, "Oui", "Non")

ICI,

  • «=SI(…)» appelle les fonctions SI
  • "E4<6000" est la condition évaluée par la fonction IF. Il vérifie que la valeur de l'adresse de cellule E4 (sous-total) est inférieure à 6,000
  • "Oui" c'est la valeur que la fonction affichera si la valeur de E4 est inférieure à 6,000
  • "Non" c'est la valeur que la fonction affichera si la valeur de E4 est supérieure à 6,000

Lorsque vous avez terminé, appuyez sur la touche Entrée

Vous obtiendrez le suiviwing de projets

Exemple de fonction SI dans Excel

Fonctions logiques Excel expliquées

Le following le tableau montre toutes les fonctions logiques dans Excel

Ratio S / N FONCTION CATÉGORIE DESCRIPTION UTILISATION
01 ET logique Vérifie plusieurs conditions et renvoie vrai si toutes les conditions sont évaluées comme vraies. =AND(1 > 0,ISNUMBER(1)) La fonction ci-dessus renvoie VRAI car les deux conditions sont vraies.
02 FAUX logique Renvoie la valeur logique FALSE. Il est utilisé pour comparer les résultats d'une condition ou d'une fonction qui renvoie vrai ou faux. FAUX()
03 IF logique Vérifie si une condition est remplie ou non. Si la condition est remplie, elle renvoie vrai. Si la condition n’est pas remplie, elle renvoie faux.
=IF(test_logique,[value_if_true],[value_if_false])
=SI(ISNUMBER(22), "Oui", "Non")
22 est un nombre pour qu'il renvoie Oui.
04 IFERREUR logique Renvoie la valeur de l'expression si aucune erreur ne se produit. Si une erreur se produit, il renvoie la valeur de l'erreur =SIERREUR(5/0, « Diviser par zéro erreur »)
05 IFNA logique Renvoie la valeur si l'erreur #N/A ne se produit pas. Si une erreur #N/A se produit, elle renvoie la valeur NA. L'erreur #N/A signifie une valeur si elle n'est pas disponible pour une formule ou une fonction. =IFNA(D6*E6,0)
NB : la formule ci-dessus renvoie zéro si les deux ou D6 ou E6 sont vides.
06 ne pas logique Renvoie vrai si la condition est fausse et renvoie faux si la condition est vraie =NON(ISTEXT(0))
NB la fonction ci-dessus renvoie vrai. En effet, ISTEXT(0) renvoie false et la fonction NOT convertit false en TRUE
07 OR logique Utilisé lors de l’évaluation de plusieurs conditions. Renvoie vrai si une ou toutes les conditions sont vraies. Renvoie false si toutes les conditions sont fausses =OR(D8=”admin”,E8=”caissier”)
NB, la fonction ci-dessus renvoie vrai si l'un ou les deux D8 et E8 administrateur ou caissier
08 VRAI logique Renvoie la valeur logique VRAI. Il est utilisé pour comparer les résultats d'une condition ou d'une fonction qui renvoie vrai ou faux. VRAI()

Fonctions IF imbriquées

Une fonction IF imbriquée est une fonction IF dans une autre fonction IF. Les instructions if imbriquées sont utiles lorsque nous devons travailler avec plus de deux conditions. Disons que nous voulons développer un programme simple qui vérifie le jour de la semaine. Si le jour est samedi, nous voulons afficher « faire la fête », si c'est dimanche, nous voulons afficher « temps de repos », et si c'est n'importe quel jour du Monday Jusqu'à vendredi que nous souhaitons afficher, pensez à compléter votre to do list.

Une fonction if imbriquée peut nous aider à implémenter l'exemple ci-dessus. Le suiviwing L'organigramme montre comment la fonction IF imbriquée sera implémentée.

Fonctions IF imbriquées dans Excel

La formule de l'organigramme ci-dessus est la suivante

=IF(B1=”Dimanche”,,”temps de repos”,IF(B1=”Samedi”,,”bien faire la fête”,,”liste de choses à faire”))

ICI,

  • «=SI(….)» est la principale fonction if
  • «=SI(…,SI(….))» la deuxième fonction IF est la fonction imbriquée. Il fournit une évaluation plus approfondie si la fonction IF principale a renvoyé faux.

Exemple pratique

Exemple pratique de fonctions IF imbriquées

Créez un nouveau classeur et entrez les données comme indiqué ci-dessous

Exemple pratique de fonctions IF imbriquées

  • Entrez le suiviwing formule

=IF(B1=”Dimanche”,,”temps de repos”,IF(B1=”Samedi”,,”bien faire la fête”,,”liste de choses à faire”))

  • Entrez samedi dans l'adresse de cellule B1
  • Vous obtiendrez le suiviwing de projets

Exemple pratique de fonctions IF imbriquées

Téléchargez le fichier Excel utilisé dans le tutoriel

Résumé

Les fonctions logiques sont utilisées pour introduire la prise de décision lors de l'évaluation formules et fonctions dans Excel.